상세 컨텐츠

본문 제목

파이썬 pip 업그레이드 중 오류 발생했을 때

IT/Python

by Analyst Cho 2021. 5. 1. 02:24

본문

반응형

언젠가부터 파이썬(Python) pip 업그레이드를 했을때마다 이상하게 오류가 발생하고 있었는데, 해결 방법이 쉬워서 다행이다.

 

pip를 최신버전으로 업그레이드 한다는 명령어

  • pip install --upgrade pip

오류 발생시 해결하는 방법

  • easy_install pip
(py32) D:\mysite>pip install --upgrade pip

Script file 'E:\Anaconda3\envs\py32\Scripts\pip-script.py' is not present.



(py32) D:\mysite>easy_install pip

WARNING: The easy_install command is deprecated and will be removed in a future version.

Searching for pip

Reading https://pypi.org/simple/pip/

Downloading https://files.pythonhosted.org/packages/fe/ef/60d7ba03b5c442309ef42e7d69959f73aacccd0d86008362a681c4698e83/pip-21.0.1-py3-none-any.whl#sha256=37fd50e056e2aed635dec96594606f0286640489b0db0ce7607f7e51890372d5

Best match: pip 21.0.1

Processing pip-21.0.1-py3-none-any.whl

Installing pip-21.0.1-py3-none-any.whl to e:\anaconda3\envs\py32\lib\site-packages

Adding pip 21.0.1 to easy-install.pth file

Installing pip-script.py script to E:\Anaconda3\envs\py32\Scripts

Installing pip.exe script to E:\Anaconda3\envs\py32\Scripts

Installing pip.exe.manifest script to E:\Anaconda3\envs\py32\Scripts

Installing pip3-script.py script to E:\Anaconda3\envs\py32\Scripts

Installing pip3.exe script to E:\Anaconda3\envs\py32\Scripts

Installing pip3.exe.manifest script to E:\Anaconda3\envs\py32\Scripts

Installing pip3.9-script.py script to E:\Anaconda3\envs\py32\Scripts

Installing pip3.9.exe script to E:\Anaconda3\envs\py32\Scripts

Installing pip3.9.exe.manifest script to E:\Anaconda3\envs\py32\Scripts



Installed e:\anaconda3\envs\py32\lib\site-packages\pip-21.0.1-py3.8.egg

Processing dependencies for pip

Finished processing dependencies for pip

Finish가 나오면 해결되었다.

반응형

관련글 더보기

댓글 영역

페이징